NetBeans com Java da Oracle

March 25, 2012   

Esse semestre puxei duas matérias com um professor que gosta muito de Java, todo o conteúdo é passado em Java e além disso alguns plugins que usamos para testes só existem no NetBeans. Nas aulas isso não é um problema, pois todos os computadores dos laboratórios possuem NetBeans instalado, mas para estudar em casa e fazer trabalhos eu precisei instalar no meu notebook.

Durante a instalação do Netbeans no Arch Linux, tive que optar por instalar alguma versão opensource do java:

julio@julio-acer ~> sudo pacman -S netbeans
resolving dependencies...
:: There are 2 providers available for java-environment:
:: Repository extra
   1) jdk7-openjdk  2) openjdk6

Enter a number (default=1):

Mas infelizmente não podia fazer isso, pois o Banco do Brasil exige que eu tenha o Java proprietário da Oracle para acessar o site e não tem como instalar ambas versões simultaneamente*.

Para resolver esse problema, basta instalar o JRE e o JDK do AUR e instalar o NetBeans ignorando as dependências:

julio@julio-acer ~> sudo pacman --nodeps --nodeps -S netbeans                                                     
looking for inter-conflicts...
Targets (1): netbeans-7.1.1-1
Total Installed Size:   500.73 MiB
Proceed with installation? [Y/n]

E pronto, o NetBeans deverá funcionar com o Java da Oracle.

Observações:

  1. Se você tentar criar um novo projeto Java pelo NetBeans e aparecer o seguinte erro:

    The JDK is missing and is required to run some NetBeans modules Please use the –jdkhome command line option to specify a JDK installation or see http://wiki.netbeans.org/FaqRunningOnJre for more information.

    É porque você provavelmente só tem o JRE. Para rodar o NetBeans também é necessário instalar o JDK, disponível no AUR.

    Instale o JDK e faça logoff e login para inclui-lo no $PATH.

  2. Se você usa algum gerenciador de janelas com tilling, como o Awesome, quando você abir o NetBeans irá aparecer apenas uma tela cinza. Para corrigir esse problema rode o seguinte comando:

    julio@julio-acer ~> wmname LG3D
    
  3. O mesmo se aplica ao Eclipse


* Possivelmente tenha com o jdk7-compat, mas manter duas versões do Java no computador é um desperdício de espaço.



comments powered by Disqus